WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

PHP Version Finder

— Add-On la WorldWideScripts.net

Aboneaza-te la feed-ul nostru pentru a rămâne până la data!

Nou! Urmați- ne cum vrei!


PHP Version Finder - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting

Urmați-mă pe Twitter Follow Me on G + Urmați-mă pe CodeCanyon Demonstrație live

Demo - Non Baza de date (infirm)
Demo - Baza de date (infirm)
Demo-urile sunt schiloditi! Ne-am bruiat adevărata versiune a fiecărei funcții și de prelungire.

Versiunea PHP Finder - Actualizat la v 1.0.3c 12/9/2010

Găsiți ce versiune de PHP script-ul cere. Când au fost întrebați ce versiune de PHP este necesar pentru a rula script-urile noastre nu am avut un răspuns definitiv. Am creat acest script pentru a determina versiunea PHP, iar apoi ne-am dus-o la un alt nivel, prin găsirea unor funcții dezaprobate. Dar nu ne-am oprit doar la asta. Am inclus PHP Extensiile și constructe lingvistice. Aproape am numit-bun la asta, dar apoi ne-am întrebat... de câte ori am folosit aceste funcții. Utilizarea excesivă a aceleiași funcții poate fi degradant asupra performanței. De monitorizare de câte ori se utilizează o funcție poate determina dacă o "Funcția creată de utilizator", pot fi create pentru a reduce codul și de a crește performanța.

Detectare

Versiunea PHP Finder Circuite: 3044 Funcții PHP, 2260 PHP Extensii, 23, 19 Limba constructe de sugestii alternative, 7 sfaturi / trucuri / Note. (Plus 69 experimental, 20 depreciată 47 de funcții "SVN")
Codul nu trebuie să fie completă, nici funcțională. Nici măcar nu trebuie să aibă sens. Atâta vreme cât este între <? Php și?> Va fi evaluat. Infirm Demo - Demo-ul a fost schilodit pentru a împiedica oamenii să folosească mai degrabă decât achiziționarea acesteia.

Oprește-te Ghicitul!

Adevăr să fie spus - cei mai mulți dezvoltatori "ball-park" ce versiune de PHP este necesară amintind câteva funcții "cheie" au folosit. Cu Versiunea PHP Finder puteți ști sigur ce este de fapt necesar versiunea PHP!
Nu Guess! - Run PHP Version Finder pe script-ul pentru a ști sigur ce verions de PHP este necesar pentru a opera script-ul!

Detectarea depreciată

Versiunea PHP Finder vă permite să aflați dacă orice funcții pe care utilizate sunt depreciate.
Retrasă Detection - Verificați scripturile pentru funcțiile depreciate

două versiuni

PHP Versiunea Finder nu necesită o bază de date. Cu toate acestea, pentru aceia dintre voi care s-ar folosi mai degrabă o bază de date, script-ul nu include o versiune de bază de date.
Optionhal Baza de date - versiunea PHP Finder nu necesită o bază de date, cu toate acestea, o versiune alternativă este furnizată pentru cei care doresc să utilizeze o bază de date.
De ce Două versiuni?
Totul se reduce la numere. În cazul în care există o mulțime de funcții PHP, versiunea de bază de date NON este mai rapid. Dacă există doar câteva funcții, versiunea de bază de date este mai rapid. Cât de mult mai rapid? Ei bine, este măsurată în micro-secunde. Deci, nu într-adevăr vizibil. Dupa ce ne-am făcut versiunea de bază de date am decis că nu merita efortul ca performanțele sale nu a fost vizibil diferit. Ne-am decis să-l includă, deoarece a fost deja construit - o freebie daca doresti.

Instalare

Instalarea este simplă. Încărcați directorul, editați două setări și ați terminat.
De instalare a aplicației - Încărcați 1 director la server, modificați un fișier de configurare și gata pentru a merge!

intrări

Aveți posibilitatea să încărcați un fișier de pe computer, scanați un fișier sau director întreg pe server, sau un cod de pastă într-o cutie pentru prelucrare.
Intrări multiple - Puteți încărca un fișier, scanați un director sau verificați un bloc de cod.

Sugestii alternative

Dacă PHP Versiunea Finder găsește funcții care sunt depreciate, vă va oferi sugestii alternative care ar putea înlocui funcția depreciate.
Sugestii alternative - Puteți face script-ul dvs. De exemplu:
dacă utilizați file_put_contents (care necesită PHP 5), PHP Versiunea Finder vă va permite să știi că ai putea folosi fwrite în schimb, care ar putea reduce versiunea necesară până la PHP 4. Nu numai că, dar există o notă atașată la file_put_contents pe care le arată codul de utilizat pentru a face file_put_contents înapoi compatibile.

Versiunea PHP Finder a achiziționa ACUM!

Asigurați-vă viața mai ușoară! Găsi funcții dezaprobate, pentru a primi sugestii înapoi compatibile și știu ce versiune de PHP este necesar pentru a rula script-urile
Achiziționați acum - face viața mai ușoară, găsiți funcții dezaprobate, pentru a primi sugestii înapoi compatibile și știu ce versiune de PHP este necesar pentru a rula script-uri.

Caracteristici v curente (1.0.0) - 12/1/2010

  • Baza de date opțională
  • Detectarea depreciată
  • Fișierul de încărcare Procesarea
  • Prelucrare director
  • Prelucrarea Cod Pasted
  • AutoComplete
  • Marcatorul de sintaxă
  • 3044 Funcții PHP
  • 2260 PHP Extensii
  • 23 constructe Limba
  • 19 Sugestii alternative
  • 7 sfaturi / trucuri / Note
  • Plus 69 Funcții experimentale
  • Plus 20 Depreciată Funcții
  • Plus 47 "SVN" / Funcții necunoscute

V 1.0.1 actualizare 12/3/2010

  • Avertismente Notice fixe
  • Fixe "Variabile nedefinită" Erori de
  • Erori de ortografie fixe
  • Actualizat Fișier Ajutor pentru a reflecta modificările
  • Adăugată Explicație licențiere
  • Curățăm "Raportați File"

V 1.0.2 actualizare 12/4/2010

  • Avertismente Notice fixe
  • Fixe "Variabile nedefinită" Erori de
  • Actualizat Fișier Ajutor pentru a reflecta modificările

V 1.0.3c actualizare 12/9/2010

  • Curățăm cod
  • Rewrote cum sunt numarate statistici.
  • A rescris "Raport File"

Descărcați
Alte componente din această categorieToate componentele acestui autor
ComentariiÎntrebări frecvente și răspunsuri

Proprietăți

Creată:
03 decembrie 10

Ultima actualizare:
10 decembrie 10

Rezoluție înaltă:
Nu

Browsere compatibile:
IE7, IE8, Safari, Opera

fişierele incluse:
JavaScript JS, HTML, CSS, PHP, SQL

Versiune de software:
PHP 4.x, PHP 5.x, PHP 5.0-5.2, PHP 5.3, MySQL 5.x

Cuvinte cheie

eCommerce, eCommerce, Toate obiectele, avertisment depreciat, versiune php, sintaxa highlighting